Материал: Sb97949

Внимание! Если размещение файла нарушает Ваши авторские права, то обязательно сообщите нам

0

МИНОБРНАУКИ РОССИИ

Санкт-Петербургский государственный электротехнический университет «ЛЭТИ» им. В. И. Ульянова (Ленина)

А. В. ГОРЯЧЕВ Н. Е. НОВАКОВА

ПРИМЕНЕНИЕ СЕТЕВЫХ ТЕХНОЛОГИЙ В КОРПОРАТИВНЫХ СИСТЕМАХ

Санкт-Петербург

2018

1

МИНОБРНАУКИ РОССИИ

Санкт-Петербургский государственный электротехнический университет «ЛЭТИ» им. В. И. Ульянова (Ленина)

А. В. ГОРЯЧЕВ Н. Е. НОВАКОВА

ПРИМЕНЕНИЕ СЕТЕВЫХ ТЕХНОЛОГИЙ В КОРПОРАТИВНЫХ СИСТЕМАХ

Учебно-методическое пособие

Санкт-Петербург Издательство СПбГЭТУ «ЛЭТИ»

2018

2

УДК 004.415.28 + 7.021.5(075) ББК З973.23 – 018я7

Г 71

Горячев А. В., Новакова Н. Е.

Г 71 Применение сетевых технологий в корпоративных системах: учеб.-метод. пособие. СПб.: Изд-во СПбГЭТУ «ЛЭТИ», 2018. 32 с.

ISBN 978-5-7629-2352-1

Посвящено изучению сетевых технологий. Включает задания к лабораторным работам, практическим занятиям и к курсовому проектированию по дисциплине «Сети ЭВМ».

Предназначено для студентов бакалавриата дневной формы обучения по направлению 220300 «Информатика и вычислительная техника».

УДК 004.415.28 + 7.021.5(075) ББК З973.23 – 018я7

Рецензент: д-р техн. наук С. Ю. Лузин (ООО «Эремекс»).

Утверждено редакционно-издательским советом университета

в качестве учебно-методического пособия

ISBN 978-5-7629-2352-1

© СПбГЭТУ «ЛЭТИ», 2018

3

ВВЕДЕНИЕ

ИТ-инфраструктура предприятия – это комплекс взаимосвязанных информационных систем и сервисов, обеспечивающих функционирование и развитие средств информационного взаимодействия предприятия. Составными частями ИТ-инфраструктуры являются корпоративные информационные системы и корпоративная сеть. Корпоративная информационная система – составная часть ИТ-инфраструктуры, которая включает в себя прикладные информационные системы, системы хранения и обработки данных, системы связи и системы совместной работы.

Основа жизнедеятельности любой информационной инфраструктуры предприятия – корпоративная сеть. Абсолютное большинство применяемых современных информационных решений требует наличия на предприятии или в организации высокопроизводительной корпоративной сети передачи данных.

Отдельные программные компоненты сети обеспечивают доступ к определенным видам сетевых ресурсов или специальным режимам их использования. Набор таких компонентов называют сетевой службой или сетевым сервисом. К базовым сетевым сервисам относятся: файловый сервис, сервис печати, сервис сообщений, сервис приложений и сервис баз данных. Основу функционирования любой компьютерной сети предприятия составляют сетевые службы DHCP, DNS, WINS. Неотъемлемой частью ИТинфраструктуры многих предприятий стала служба каталога. Помимо базовых сетевых сервисов на многих предприятиях используются специализированные средства управления сетевой инфраструктурой, средства мониторинга и системы защиты информационной безопасности.

В данном издании рассматриваются основы сетевых технологий – сетевые службы, обеспечивающие функционирование корпоративной сети.

4

1. СТЕК ПРОТОКОЛОВ TCP/IP

Термин «TCP/IP» объединяет всё, связанное с протоколами TCP и IP: другие сетевые протоколы, приложения и даже каналы передачи данных.

Протоколы разбиваются на уровни, и протоколы более высоких уровней задействуют протоколы более низких – инкапсулируют их. Набор протоколов TCP/IP называют стеком. В стеке протоколов TCP/IP выделяют 4 уровня, каждый из которых отвечает за свою фазу коммуникаций.

Канальный уровень обеспечивает аппаратную поддержку физического соединения узла со средой передачи данных, а также определяет, каким образом пакеты данных передаются по ней. Он объединяет в себе интерфейсное устройство узла и её драйвер. Пример протокола этого уровня – ARP (RFC 826). К канальному уровню также относятся все аппаратно-специфичные протоколы

– такие, например, как Ethernet и IEEE 802.11 (Wi-Fi).

Сетевой уровень – это уровень IP. Его часто называют уровнем межсетевого взаимодействия, чем подчёркивается его главное отличие от канального уровня. Протоколы последнего способны обеспечить обмен данными только между узлами, непосредственно объединёнными в одну сеть. На сетевом уровне осуществляется маршрутизация пакетов, а значит, существует возможность передачи пакета между различными сетями. Примеры протоколов этого уровня – IP (RFC 791), ICMP (RFC 792), IGMP (RFC 3376).

Транспортный уровень обеспечивает сетевым приложениям (т. е. протоколам верхнего уровня) сквозную передачу потоков данных. На транспортном уровне появляется понятие порта, которое обеспечивает возможность одновременной работы нескольких сетевых приложений с одним сетевым интерфейсом. Основные протоколы этого уровня – TCP и UDP. TCP (RFC 793) обеспечивает надёжную передачу данных между узлами, контролируя доставку каждого пакета адресату. UDP (RFC 768) обеспечивает более простой, но и более быстрый сервис, не дающий никаких гарантий доставки.

Уровень приложений определяет детали, специфичные для конкретных сетевых приложений. Если транспортный уровень обеспечивает соединение «хост – хост», то уровень приложений – соединение «процесс – процесс». На уровне приложений работают протоколы, в большинстве своём основанные на TCP или UDP. Примеры прикладных протоколов, использующих TCP, – это

Источник: https://studfile.net/preview/16439027/