Материал: Sb97949

Внимание! Если размещение файла нарушает Ваши авторские права, то обязательно сообщите нам

10

в сетях IPv6 определены некоторые перманентные групповые IPv6-адреса. Например, аналогом адреса 224.0.0.1 для IPv6 является ff02::1 (RFC 2375).

На смену IGMP в IPv6 пришёл протокол MLD – Multicast Listener Discovery.

Для обмена информацией об участии в группах хосты и маршрутизаторы используют сообщения ICMPv6 (RFC 2710). В остальном механизм управления группами в сетях IPv6 схож с механизмом управления группами в сетях IPv4: маршрутизаторы рассылают запросы локальным хостам, а те в ответ отправляют им список всех групп, к которым принадлежат, либо подтверждение принадлежности к конкретной группе, интересующей маршрутизатор.

2.5. Назначение IP-адресов

Адрес узла может быть фиксирован (аппаратно или программно) либо назначен ему при присоединении к сети. В первом случае говорят, что узел имеет статический IP-адрес, а во втором – динамический IP-адрес.

Статический адрес назначается администратором непосредственно на узле. Для назначения динамического адреса существует несколько способов.

В «штатных условиях» динамические IP-адреса назначаются узлам сервером DHCP (Dynamic Host Configuration Protocol), он будет рассмотрен в 5.

В случае отсутствия или неработоспособности DHCP-сервера узлы должны быть способны назначить себе адрес самостоятельно. Для этого в IPv4 выделен диапазон 169.254.0.0/16 (RFC 3927), а в IPv6 – fe80::/10 (RFC 4862). Это позволяет узлам сети взаимодействовать друг с другом, однако такие адреса не маршрутизируются за пределы сети – в том числе и в Интернет.

3. МАРШРУТИЗАЦИЯ

IP-маршрутизация – это довольно простой процесс, особенно с точки зрения хоста. Если пункт назначения напрямую подключён к хосту (например, канал точка–точка) или хост включён между несколькими сетями (Ethernet или Token ring), IP-датаграмма направляется непосредственно в пункт назначения, иначе хост посылает датаграмму на маршрутизатор по умолчанию, тем самым предоставляя маршрутизатору решать вопрос как доставить датаграмму в пункт назначения. Эту простую схему реализуют практически все хосты [3].

IP-уровень может быть сконфигурирован таким образом, чтобы выполнять функции маршрутизации в дополнение к тому, что он работает в качестве сетевого интерфейса. Основная и фундаментальная разница между

11

хостом и маршрутизатором заключается в том, что хост никогда не перенаправляет датаграммы с одного своего интерфейса на другой, тогда как маршрутизатор их перенаправляет.

IP может получать датаграммы от собственных уровней TCP, UDP, ICMP и IGMP (это датаграммы, формирующиеся здесь же), которые необходимо отправить, однако датаграммы могут быть приняты с какого-либо сетевого интерфейса (эти датаграммы должны быть перенаправлены). IP-уровень имеет

впамяти таблицу маршрутизации, которую он просматривает каждый раз при получении датаграммы, которую необходимо перенаправить. Когда датаграмма принята с сетевого интерфейса, IP, во-первых, проверяет, не принадлежит ли ему указанный IP-адрес назначения или не является ли этот IP-адрес широковещательным. Если это так, то датаграмма доставляется в модуль протокола, указанный в поле протокола в IP-заголовке. Если датаграмма не предназначается для этого IP-уровня, то пакет перенаправляется (в этом случае датаграмма обрабатывается как исходящая), если IP-уровень был сконфигурирован для работы в качестве маршрутизатора, иначе датаграмма уничтожается.

Каждый пункт таблицы маршрутизации содержит следующую информацию:

IP-адрес назначения. Это может быть полный адрес хоста (host address) или адрес сети (network address), что указывается в поле флагов (описывается ниже). Адрес хоста имеет ненулевое значение идентификатора хоста и указывает на один конкретный хост, тогда как адрес сети имеет идентификатор хоста, установленный

в0, и указывает на все хосты, включённые в опредёленную сеть (Ethernet, Token Ring).

IP-адрес маршрутизатора следующей пересылки (next-hop router), или, другими словами, IP-адрес непосредственно подключённой сети. Маршрутизатор следующей пересылки принадлежит одной из непосредственно подключённых сетей, в которую можно отправить датаграммы для их доставки. Маршрутизатор следующей пересылки – это не конечный пункт назначения, однако он принимает отправленные датаграммы и перенаправляет их в направлении конечного пункта.

Флаги. Один флаг указывает, является ли IP-адрес пункта назначения адресом сети или адресом хоста. Другой флаг указывает на то, является ли маршрутизатор следующей пересылки действительно маршрутизатором или это непосредственно подключённый интерфейс.

12

Указание на сетевой интерфейс, на который должны быть переданы датаграммы для передачи.

IP-маршрутизация осуществляется по принципу «пересылка за пересылкой». Как видно из таблицы маршрутизации, IP не знает полный маршрут к пункту назначения (за исключением тех пунктов назначения, которые непосредственно подключены к посылающему хосту). Всё, что может предоставить IP-маршрутизация – это IP-адрес маршрутизатора следующей пересылки, на который отправляется датаграмма. При этом предполагается, что маршрутизатор следующей пересылки ближе к пункту назначения, чем посылающий хост. Также делается предположение, что маршрутизатор следующей пересылки напрямую подключён к посылающему хосту.

IP-маршрутизация осуществляет следующие действия:

1.Поиск в таблице маршрутизации – при этом ищется пункт, который совпадет с полным адресом пункта назначения (должны совпасть идентификатор сети и идентификатор хоста). Если пункт найден, пакет посылается на указанный маршрутизатор следующей пересылки или на непосредственно подключённый интерфейс (в зависимости от поля флагов). Как правило, так определяются каналы точка–точка, при этом другой конец такого канала, как правило, является полным IP-адресом удалённого хоста.

2.Осуществляется поиск в таблице маршрутизации пункта, который совпадет как минимум с идентификатором сети назначения. Если пункт найден, пакет отправляется на указанный маршрутизатор следующей пересылки или на непосредственно подключённый интерфейс (в зависимости от поля флагов). Маршрутизация ко всем хостам, находящимся в сети назначения, осуществляется

сиспользованием этого единственного пункта таблицы маршрутизации. (Например, все хосты локальной сети Ethernet представляются в таблицах маршрутизации именно таким образом.) Эта проверка совпадения идентификатора сети осуществляется с использованием возможной маски подсети.

3.В таблице маршрутизации ищется пункт, помеченный «по умолчанию» (default). Если пункт найден, пакет отсылается на указанный маршрутизатор по умолчанию.

13

A, .13.35

B, .13.33

Ethernet, 140.252.13

link

IP

 

 

hdr

hdr

 

 

 

 

 

 

Назначение IP = 140.252.13.33

Рассмотрим еще один пример: A имеет IP-датаграмму, которую необходимо послать на хост ftp.uu.net, IP-адрес которого – 192.48.96.9. На рисунке показан путь датаграммы к первому маршрутизатору. A просматривает свою таблицу маршрутизации, однако не находит совпадающий хост или совпадающую сеть. Он использует пункт таблицы маршрутизации по умолчанию, в соответствии с которым необходимо послать датаграмму на B, который является маршрутизатором следующей пересылки. Когда датаграмма передается от A к B, IP-адрес для неё – это конечный адрес назначения (192.48.96.9), однако адрес канального уровня – это 48-битный Ethernet-адрес интерфейса Ethernet-машины B.

Когда B получает датаграмму, он понимает, что IP-адрес назначения этой датаграммы – не его собственный, и если B сконфигурирован для выполнения функций маршрутизатора, он перенаправляет датаграмму. Происходит просмотр его таблицы маршрутизации, в результате чего выбирается пункт по умолчанию. Из этого пункта следует, что B должен перенаправить датаграмму на маршрутизатор следующей пересылки – C, IP-адрес которого, например, 140.252.13.183. Датаграмма пересылается по PPP-каналу точка–точка с использованием минимальной инкапсуляции, показанной на рисунке. Заголовок канального уровня не показан, как в случае с Ethernet, потому что его не существует для PPP-канала.

Когда C получает датаграмму, он поступает аналогично B: датаграмма не предназначается какому-либо из его IP-адресов, а поскольку C сконфигурирован так, чтобы выполнять функции маршрутизатора, он перенаправляет датаграмму. В данном случае также используется пункт таблицы маршрутизации по

14

умолчанию, при этом датаграмма посылается на маршрутизатор следующей пересылки D (140.252.1.4). Используя ARP в сети Ethernet 140.252.1, C получает

48-битный Ethernet-адрес, соответствующий адресу 140.252.1.4. Именно этот Ethernet-адрес становится адресом назначения в заголовке канального уровня.

D осуществляет те же шаги, что и 2 предыдущих маршрутизатора; в его таблице маршрутизации пункт по умолчанию указывает на адрес 140.252.104.2 как на адрес маршрутизатора следующей пересылки.

Из приведённого примера можно сделать несколько важных выводов:

1.Все хосты и маршрутизаторы в данном примере используют маршрут по умолчанию.

2.IP-адрес назначения датаграммы никогда не меняется. Все решения о маршрутизации основываются на этом адресе назначения.

Для каждого канала могут быть использованы различные заголовки канального уровня, а адрес назначения канального уровня (если присутствует) всегда содержит адрес маршрутизатора следующей пересылки. В данном примере датаграммы, инкапсулированные во фреймы канального уровня, содержали Ethernet-адрес следующей пересылки, однако PPP не содержал.

4. NAT

Трансляция сетевых адресов (Network Address Translation, NAT) –

механизм замены информации о сетевых адресах в заголовках IP-пакетов в процессе их передачи через маршрутизирующие устройства. Трансляция производится с целью отображения одного адресного пространства IP на другое, «прозрачное» для конечных пользователей.

Многие компании выбирают для своей сети частные IP-адреса, чтобы сэкономить на приобретении общих IP-адресов. Применение частных IPадресов – эффективное и недорогое решение, но оно не дает пользователям прямого доступа к Интернету. В таких случаях для обеспечения связи с Интернетом нужно преобразовывать частные IP-адреса в маршрутизируемые общие адреса. NAT позволяет небольшим компаниям, использующим схему адресации для частной сети, подключаться к ресурсам Интернета. IP-адреса, приведенные в табл. 4.1, маршрутизируемы только в частных или корпоративных сетях и не маршрутизируются в Интернете.

Если узлу сети или рабочей станции назначить такой IP-адрес, подключить его к Интернету будет невозможно.

Источник: https://studfile.net/preview/16439027/